Service Degradation

Incident Report for ID.me

Resolved

This incident has been resolved
Posted May 16, 2023 - 21:21 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 16, 2023 - 21:17 EDT

Identified

The issue has been identified and our team is working on a fix.
Posted May 16, 2023 - 20:41 EDT

Investigating

We're experiencing an elevated level of application errors and are currently looking into the issue. Status updates will be provided as soon as available.
Posted May 16, 2023 - 20:21 EDT
This incident affected: ID.me Shop.