Verification Services Outage

Incident Report for ID.me

Resolved

Fix by Third Party Provider appears to have resolved the issue. We will continue to monitor to ensure services are stable and fully restored.
Posted Jul 14, 2026 - 04:45 EDT

Monitoring

Third party provider has implemented a fix and we are monitoring the results.
Posted Jul 14, 2026 - 04:27 EDT

Update

We are continuing to work with our third-party provider on a fix.
Next update at 4:30 AM ET.
Posted Jul 14, 2026 - 03:31 EDT

Investigating

Third-party service that is a component of Verifications Services is currently experiencing an outage. We are working with the Third-party provider on a fix.
We will provide an update at 3:30 AM ET.
Posted Jul 14, 2026 - 02:29 EDT
This incident affected: Identity Verification (NIST 800-63-3 Policies, NIST 800-63-2 Policies, KBA-replacement Policies, Telecom Possession API, Telecom Identity API, Document Identity API).