Broad Google Cloud outage impacting ID.me

Incident Report for ID.me

Resolved

All services are working within operational parameters.
Posted Jun 13, 2025 - 09:24 EDT

Monitoring

All services are operational. There maybe intermittent issues until the Google Cloud Platform incident is resolved. The team will continue to monitor
Posted Jun 12, 2025 - 16:46 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 16:41 EDT

Investigating

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 14:48 EDT
This incident affected: Identity Verification (NIST 800-63-3 Policies, NIST 800-63-2 Policies, KBA-replacement Policies, Telecom Possession API, Telecom Identity API, Document Identity API).