Login Service Degradation
Incident Report for ID.me
Resolved
The incident has been resolved and platform is fully operational
Posted Dec 06, 2022 - 12:29 EST
Identified
The performance degradation source has been identified and remediating
Posted Dec 06, 2022 - 12:26 EST
Investigating
We are investigating a degradation with user login services and account management
Posted Dec 06, 2022 - 11:57 EST
This incident affected: Account Management and Login Services.