Processing Delays
Incident Report for ID.me
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 19:26 EST
Monitoring
Processing delays have recovered and we will continue to monitor.
Posted Jan 19, 2024 - 19:16 EST
Update
We are continuing to investigate this issue.
Posted Jan 19, 2024 - 19:14 EST
Investigating
The application platform is currently experiencing request processing delays. The ID.me Engineering team is currently investigation the issue and will provide updates as soon as they become available.
Posted Jan 19, 2024 - 19:05 EST
This incident affected: Wallet Account Access and Management (Login Services) and Identity Verification (NIST 800-63-3 Policies, NIST 800-63-2 Policies, KBA-replacement Policies).