Service Provider Degradation
Incident Report for ID.me
Resolved
This incident has been resolved.
Posted Jan 29, 2024 - 18:54 EST
Monitoring
A fix has been implemented and we will continue to monitor.
Posted Jan 29, 2024 - 18:13 EST
Investigating
We're experiencing an elevated level of application errors due to a service provider degradation and are currently looking into the issue. Status updates will be provided as soon as available.
Posted Jan 29, 2024 - 17:17 EST
This incident affected: Wallet Account Access and Management (Login Services) and Identity Verification (NIST 800-63-3 Policies, NIST 800-63-2 Policies).